// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_\D+").unwrap();
let string = "KM1208_sta1_cast3
KM1208_sta1_cast6a
KM1208_sta1_cast6b
KM1208_sta2_cast7
KM1208_sta2_cast6
HS1301_sta1_cast2
HS1301_sta2_cast5
HS1301_sta3_cast8
HS1301_sta3_cast9";
let substitution = ",";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}