use strict;
my $str = 'KM1208_sta1_cast3
KM1208_sta1_cast6a
KM1208_sta1_cast6b
KM1208_sta2_cast7
KM1208_sta2_cast6
HS1301_sta1_cast2
HS1301_sta2_cast5
HS1301_sta3_cast8
HS1301_sta3_cast9';
my $regex = qr/_\D+/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";