using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_\D+";
string substitution = @",";
string input = @"KM1208_sta1_cast3
KM1208_sta1_cast6a
KM1208_sta1_cast6b
KM1208_sta2_cast7
KM1208_sta2_cast6
HS1301_sta1_cast2
HS1301_sta2_cast5
HS1301_sta3_cast8
HS1301_sta3_cast9";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}