import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_\\D+";
final String string = "KM1208_sta1_cast3\n"
+ "KM1208_sta1_cast6a\n"
+ "KM1208_sta1_cast6b\n"
+ "KM1208_sta2_cast7\n"
+ "KM1208_sta2_cast6\n"
+ "HS1301_sta1_cast2\n"
+ "HS1301_sta2_cast5\n"
+ "HS1301_sta3_cast8\n"
+ "HS1301_sta3_cast9";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}