$re = '/_\D+/m';
$str = 'KM1208_sta1_cast3
KM1208_sta1_cast6a
KM1208_sta1_cast6b
KM1208_sta2_cast7
KM1208_sta2_cast6
HS1301_sta1_cast2
HS1301_sta2_cast5
HS1301_sta3_cast8
HS1301_sta3_cast9';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;