import Foundation
let pattern = #"_\D+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
KM1208_sta1_cast3
KM1208_sta1_cast6a
KM1208_sta1_cast6b
KM1208_sta2_cast7
KM1208_sta2_cast6
HS1301_sta1_cast2
HS1301_sta2_cast5
HS1301_sta3_cast8
HS1301_sta3_cast9
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)