#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:\s+|\bJoker\b)*)\S((?:\s+Joker)*\s*$)?"
Local $sString = "Joker nana Joker Joker Joker "
Local $sSubst = "\1$\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)