package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:\s+|\bJoker\b)*)\S((?:\s+Joker)*\s*$)?`)
var str = `Joker nana Joker Joker Joker `
var substitution = "\1$\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}