import re
regex = re.compile(r"((?:\s+|\bJoker\b)*)\S((?:\s+Joker)*\s*$)?", flags=re.MULTILINE)
test_str = "Joker nana Joker Joker Joker "
subst = "\\1$\\2"
result = regex.sub(subst, test_str)
if result:
print(result)