use strict;
my $str = 'Joker nana Joker Joker Joker ';
my $regex = qr/((?:\s+|\bJoker\b)*)\S((?:\s+Joker)*\s*$)?/mp;
my $subst = '\\1$\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";