re = /((?:\s+|\bJoker\b)*)\S((?:\s+Joker)*\s*$)?/m
str = 'Joker nana Joker Joker Joker '
subst = '\\1$\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result