$re = '/((?:\s+|\bJoker\b)*)\S((?:\s+Joker)*\s*$)?/m';
$str = 'Joker nana Joker Joker Joker ';
$subst = "\1$\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;