const regex = /((?:\s+|\bJoker\b)*)\S((?:\s+Joker)*\s*$)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\s+|\\bJoker\\b)*)\\S((?:\\s+Joker)*\\s*$)?', 'gm')
const str = `Joker nana Joker Joker Joker `;
const subst = `\1$\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);