$re = '/.*?(\b(?:to|for|with)\b.*)/m';
$str = 'I wish to check my python code for errors to run the program properly with fluency';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;