re = /.*?(\b(?:to|for|with)\b.*)/m
str = 'I wish to check my python code for errors to run the program properly with fluency'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result