#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?P<qualifier>[+?~-])?(?P<is_a>a)(?:[:])?(?P<a_mechanism>.+)?"
Local $sString = "a" & @CRLF & _
"a:example.com" & @CRLF & _
"+a:example.com" & @CRLF & _
"a:mailers.example.com" & @CRLF & _
"~a:mailers.example.com" & @CRLF & _
"a/24" & @CRLF & _
"-a:offsite.example.com/24" & @CRLF & _
"?a:example.com/24" & @CRLF & _
"+mx:mail.example.com" & @CRLF & _
"mx" & @CRLF & _
"ip4:192.168.11.0/32"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")