use strict;
my $str = 'a
a:example.com
+a:example.com
a:mailers.example.com
~a:mailers.example.com
a/24
-a:offsite.example.com/24
?a:example.com/24
+mx:mail.example.com
mx
ip4:192.168.11.0/32';
my $regex = qr/^(?P<qualifier>[+?~-])?(?P<is_a>a)(?:[:])?(?P<a_mechanism>.+)?/imp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}