import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<qualifier>[+?~-])?(?P<is_a>a)(?:[:])?(?P<a_mechanism>.+)?";
final String string = "a\n"
+ "a:example.com\n"
+ "+a:example.com\n"
+ "a:mailers.example.com\n"
+ "~a:mailers.example.com\n"
+ "a/24\n"
+ "-a:offsite.example.com/24\n"
+ "?a:example.com/24\n"
+ "+mx:mail.example.com\n"
+ "mx\n"
+ "ip4:192.168.11.0/32";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}