# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\w\d\s]//gm;t' <<< "Body: \"This is the body, where you can find lots of special characters. Hello, \"this\" is my search string without the correct punctdsuation.\"ds"