import Foundation
let pattern = #"[^\w\d\s]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Body: "This is the body, where you can find lots of special characters. Hello, "this" is my search string without the correct punctdsuation."ds"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)