use strict;
my $str = 'Body: "This is the body, where you can find lots of special characters. Hello, "this" is my search string without the correct punctdsuation."ds';
my $regex = qr/[^\w\d\s]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";