$re = '/[^\w\d\s]/m';
$str = 'Body: "This is the body, where you can find lots of special characters. Hello, "this" is my search string without the correct punctdsuation."ds';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;