// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\w\d\s]").unwrap();
let string = "Body: \"This is the body, where you can find lots of special characters. Hello, \"this\" is my search string without the correct punctdsuation.\"ds";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}