package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\w\d\s]`)
var str = `Body: "This is the body, where you can find lots of special characters. Hello, "this" is my search string without the correct punctdsuation."ds`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}