#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^\w\d\s]"
Local $sString = "Body: "This is the body, where you can find lots of special characters. Hello, "this" is my search string without the correct punctdsuation."ds"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)