#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(module\.exports\s?=\s?|exports\.default\s?=\s?|export default )"(.*)";?"
Local $sString = "module.exports = "<div class="blah"></div>";" & @CRLF & _
"exports.default="goodbye"" & @CRLF & _
"export default "foobar"" & @CRLF & _
"export default """ & @CRLF & _
"<div class=""></div>" & @CRLF & _
"'""'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")