// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(module\.exports\s?=\s?|exports\.default\s?=\s?|export default )"(.*)";?"#).unwrap();
let string = "module.exports = \"<div class=\"blah\"></div>\";
exports.default=\"goodbye\"
export default \"foobar\"
export default \"\"
<div class=\"\"></div>
'\"\"'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}