const regex = /(module\.exports\s?=\s?|exports\.default\s?=\s?|export default )"(.*)";?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(module\\.exports\\s?=\\s?|exports\\.default\\s?=\\s?|export default )"(.*)";?', 'gm')
const str = `module.exports = "<div class="blah"></div>";
exports.default="goodbye"
export default "foobar"
export default ""
<div class=""></div>
'""'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}