package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(module\.exports\s?=\s?|exports\.default\s?=\s?|export default )"(.*)";?`)
var str = `module.exports = "<div class="blah"></div>";
exports.default="goodbye"
export default "foobar"
export default ""
<div class=""></div>
'""'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}