$re = '/(module\.exports\s?=\s?|exports\.default\s?=\s?|export default )"(.*)";?/m';
$str = 'module.exports = "<div class="blah"></div>";
exports.default="goodbye"
export default "foobar"
export default ""
<div class=""></div>
\'""\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);