re = /(module\.exports\s?=\s?|exports\.default\s?=\s?|export default )"(.*)";?/m
str = 'module.exports = "<div class="blah"></div>";
exports.default="goodbye"
export default "foobar"
export default ""
<div class=""></div>
\'""\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end