import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(module\\.exports\\s?=\\s?|exports\\.default\\s?=\\s?|export default )\"(.*)\";?";
final String string = "module.exports = \"<div class=\"blah\"></div>\";\n"
+ "exports.default=\"goodbye\"\n"
+ "export default \"foobar\"\n"
+ "export default \"\"\n"
+ "<div class=\"\"></div>\n"
+ "'\"\"'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}