package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(thedir[ ]*=[ ]*")(.)(:[\/\\])([a-zA-Z0-9]*)([\/\\]?.*)$`)
var str = `thedir="C:/oneFolder/subfolder"
thedir="C:/oneFolder/"`
var substitution = "$1Z$3Here$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}