$re = '/^(thedir[ ]*=[ ]*")(.)(:[\/\\\\])([a-zA-Z0-9]*)([\/\\\\]?.*)$/m';
$str = 'thedir="C:/oneFolder/subfolder"
thedir="C:/oneFolder/"';
$subst = "$1Z$3Here$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;