import re
regex = re.compile(r"^(thedir[ ]*=[ ]*\")(.)(:[\/\\])([a-zA-Z0-9]*)([\/\\]?.*)$", flags=re.MULTILINE)
test_str = ("thedir=\"C:/oneFolder/subfolder\"\n"
"thedir=\"C:/oneFolder/\"")
subst = "$1Z$3Here$5"
result = regex.sub(subst, test_str)
if result:
print(result)