re = /^(thedir[ ]*=[ ]*")(.)(:[\/\\])([a-zA-Z0-9]*)([\/\\]?.*)$/m
str = 'thedir="C:/oneFolder/subfolder"
thedir="C:/oneFolder/"'
subst = '$1Z$3Here$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result