const regex = /^[a-zA-Z\d-]{1,100}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z\\d-]{1,100}', 'gm')
const str = `RE-1234-56-789-0
123-AB-12-INV
123456789
ABCDE
2019-01-19-ABCD
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}