use strict;
my $str = 'RE-1234-56-789-0
123-AB-12-INV
123456789
ABCDE
2019-01-19-ABCD
';
my $regex = qr/^[a-zA-Z\d-]{1,100}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}