import re
regex = re.compile(r"^[a-zA-Z\d-]{1,100}", flags=re.MULTILINE)
test_str = ("RE-1234-56-789-0\n"
"123-AB-12-INV\n"
"123456789\n"
"ABCDE\n"
"2019-01-19-ABCD\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")