re = /^[a-zA-Z\d-]{1,100}/m
str = 'RE-1234-56-789-0
123-AB-12-INV
123456789
ABCDE
2019-01-19-ABCD
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end