using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*style[^>]*>([\s\S]*?)<\s*\/\s*style>";
string input = @"<style>
p {
color: purple;
font-family: 'Comic Sans MS';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style lang=""scss"">
p {
color: purple;
font-family: 'Comic Sans MS';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style>.asd</style>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}