package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\s*style[^>]*>([\s\S]*?)<\s*\/\s*style>`)
var str = `<style>
p {
color: purple;
font-family: 'Comic Sans MS';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style lang="scss">
p {
color: purple;
font-family: 'Comic Sans MS';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style>.asd</style>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}