re = /<\s*style[^>]*>([\s\S]*?)<\s*\/\s*style>/
str = '<style>
p {
color: purple;
font-family: \'Comic Sans MS\';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style lang="scss">
p {
color: purple;
font-family: \'Comic Sans MS\';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style>.asd</style>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end