const regex = /<\s*style[^>]*>([\s\S]*?)<\s*\/\s*style>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*style[^>]*>([\\s\\S]*?)<\\s*\\\/\\s*style>', 'g')
const str = `<style>
p {
color: purple;
font-family: 'Comic Sans MS';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style lang="scss">
p {
color: purple;
font-family: 'Comic Sans MS';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style>.asd</style>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}