$re = '/<\s*style[^>]*>([\s\S]*?)<\s*\/\s*style>/';
$str = '<style>
p {
color: purple;
font-family: \'Comic Sans MS\';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style lang="scss">
p {
color: purple;
font-family: \'Comic Sans MS\';
font-size: 2em;
}
</style>
<p>These styles...</p>
<style>.asd</style>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);