#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^e\s]|[^l]e|[^f]le|[^f]fle|[^a]ffle|[^b]affle)\s*(needle)"
Local $sString = "baffle needle buffalo" & @CRLF & _
"baffle needlebaffle fine" & @CRLF & _
"baffle" & @CRLF & _
"needle baffleneedle baffle" & @CRLF & _
"" & @CRLF & _
"fine" & @CRLF & _
"baffle buffalo" & @CRLF & _
"needle buffalo needle" & @CRLF & _
"baffle needle" & @CRLF & _
"needle baffle fine" & @CRLF & _
"needlefine"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")