import re
regex = re.compile(r"([^e\s]|[^l]e|[^f]le|[^f]fle|[^a]ffle|[^b]affle)\s*(needle)", flags=re.MULTILINE)
test_str = ("baffle needle buffalo\n"
"baffle needlebaffle fine\n"
"baffle\n"
"needle baffleneedle baffle\n\n"
"fine\n"
"baffle buffalo\n"
"needle buffalo needle\n"
"baffle needle\n"
"needle baffle fine\n"
"needlefine")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")