import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^e\\s]|[^l]e|[^f]le|[^f]fle|[^a]ffle|[^b]affle)\\s*(needle)";
final String string = "baffle needle buffalo\n"
+ "baffle needlebaffle fine\n"
+ "baffle\n"
+ "needle baffleneedle baffle\n\n"
+ "fine\n"
+ "baffle buffalo\n"
+ "needle buffalo needle\n"
+ "baffle needle\n"
+ "needle baffle fine\n"
+ "needlefine";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}