re = /([^e\s]|[^l]e|[^f]le|[^f]fle|[^a]ffle|[^b]affle)\s*(needle)/m
str = 'baffle needle buffalo
baffle needlebaffle fine
baffle
needle baffleneedle baffle
fine
baffle buffalo
needle buffalo needle
baffle needle
needle baffle fine
needlefine'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end