using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=npm start)([^=\n]+)(?:=?)(?:['""]+)?([^\n\'\""]+)?(?:[^\S\n]?)";
string input = @"npm start search=test
npm start search=test, bal,sdf
npm start search=test, bal,sdf
npm start package-name
npm start package-name=test-search, 123, sdfasf
npm start search='test'
npm start search='test, bal,sdf'
npm start search='test, bal,sdf '
npm start package-name
npm start package-name='test-search, 123, sdfasf '
npm start search=""test""
npm start search=""test, bal,sdf""
npm start search=""test, bal,sdf ""
npm start package-name
npm start package-name=""test-search, 123, sdfasf """;
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}